Alfa Romeo Car Problems & Fixes

Alfa Romeo owner problems and repairs

Below is a list of Alfa Romeo cars and the total problems we have in our database for that model. You can add your own problems by clicking the 'Post a new problem' buttons around the site.

Current Models
Legacy Models
Don't see your car model?

We only list the cars here that have problems, you can add a problem for any model.

Have a problem with your Alfa Romeo?
Tell us about your problem now and get suggestions and fixes.
The Latest Alfa Romeo Problems
1
response
Timing Belt Cracked

A Friends Car - The Timing belt has cracked on the Alfa. Does anyone know if the Valves actually come down into the Combustion chamber. I am trying to ascertain if he should just go away and do the Be...

2005 Alfa Romeo 147 T Spark 1.6
Posted: Oct 9, 2012
1
response
Gear changing

When trying to select reverse it will not engage from neutral.have select gear one & go straight to reverse which is noisy.also when changing up from gear one to gear two it drops into neutral & will ...

2002 Alfa Romeo 147 2.0 selespeed
Posted: Sep 12, 2012
2
responses
Overheating

just bought car within 1 week temp light came on ,topped up coolant level and bled system almost a week later same happend, temp up over 90 dgrsbut cooling fan worked header tank empty

2006 Alfa Romeo 147 t spark
Posted: May 22, 2011
2
responses
Speedometer

the speedometer only indicates half of the actual speed. So when I am driving of about 80 km/hour the dial only shows 40 km/hour.

2000 Alfa Romeo 156 2.5 auto
Posted: May 11, 2011
0
responses
Where do we begin?

Has anyone experienced any of the following issues with their car? Car is 7 months old and as had to go back on separate occasions for the following items to be attended to: flaking paint on front h...

2010 Alfa Romeo Giulietta 1.9 diesel
Posted: Apr 11, 2011
1
response
Engine coolant

Hi every1, A bit of a stupid question but here goes. I've just purchased an Alfa Romeo and the engine coolants nearly ran out. I've struggled to purchase the recomended engine coolant in log book. Th...

2001 Alfa Romeo 156 saloon
Posted: Nov 27, 2010
1
response
Slight tinny sound at high revs

Hi everyone, When the revs it top end of 2 to 3 on rev counter theres a slight tinny noise coming from the engine. Additionally, the noise occurs going up steep hills. Although, it's not causing any ...

2001 Alfa Romeo 156 Manual saloon
Posted: Nov 15, 2010
1
response
Slightly Fluctuation with Temprature Gage.

Hi, I've recently purchased an Alfo Romeo. And after driving for an hour or so the temprature gage fluctuates slightly around the halfway mark. Although, this only happens when stuck in traffic i.e t...

2000 Alfa Romeo 156 156 TS Saloon
Posted: Nov 5, 2010
2
responses
Overheating

engine coolant levels warning light comes on after about 5 miles. Air con and heating works until this happens at which point they fail. Have replaced thermostat. Pipes are hot. Not losing any fluid...

2005 Alfa Romeo 147
Posted: Jul 5, 2010
2
responses
Heater

Car seems to take along time to warm up as in the warm air blower & i think it could be the thermostat as the radiator isnt very old along with the water pump,can any anybody advise on the problem or ...

1998 Alfa Romeo 145 cloverleaf 2.0L
Posted: Feb 23, 2010
0
responses
Loss of power when i put my foot down an makes a miss fire sound

doesnt always do it but when i put my foot down i second gear it starts makin a noise from engine an starts to chugger an lose power!!

2002 Alfa Romeo 147 1.6 t spark tourismo
Posted: Dec 30, 2009
2
responses
Engine power loss

i've got alfa156 and what the problem seems to be now is..when i put the foot down it feels like there is more air being sucked in than fuel so..there is power loss...it is mostly at 1000 rpm to 2000 ...

2000 Alfa Romeo 156 ts veloce
Posted: Nov 1, 2009
0
responses
Starting computer fault? !!

Hi, Can anyone help me regarding my alfa, recently I have been having random errors messages on dash screen only for them not be valid.i.e. side light showing out when ok abs problems again no problem...

2002 Alfa Romeo 147 2.0 lusso
Posted: Aug 6, 2009
1
response
Blowing Noise

Have just drove to town and back at lunchtime, car was fine on the way, on way back started to get a bit of a blowing noise from the rear of the engine bay when over 3000 rpm, theres no loss in power ...

2004 Alfa Romeo 156 1.9JTD Veloce M-Jet
Posted: Jul 15, 2008
0
responses
Beeping sound

The car is beeping almost all the time and its very annoying.The beeping sound comes more when i travel longer distance,hitting holes on the road ,starting the engine & even closing the door

2001 Alfa Romeo 147 1.6 manual
Posted: Apr 20, 2008
3
responses
Bloody alfas

After my engine mysteriously going bang in fifth gear at approx 70mph(not exactly straining a 2L!) i have a constant smell of burning oil in the ventilation system. any ideas how to rectify it without...

2001 Alfa Romeo 156 2.0 veloce
Posted: Dec 19, 2007
2
responses
GT drinking oil

My GT is absolutely guzzling the oil at the moment. I'm going through a litre every 10 days/ fortnight or so... the "low oli pressure" light comes on and I pull over - sure enough, the oil is bone dry...

2005 Alfa Romeo GT petrol
Posted: Oct 23, 2007
On Social Media