Gear changing
2002 Alfa Romeo 147 2.0 selespeed

Avatar
BrianDonnelly
Driver
1 points

Problem added: Sep 12, 2012 (8 years ago)
When trying to select reverse it will not engage from neutral.have select gear one & go straight to reverse which is noisy.also when changing up from gear one to gear two it drops into neutral & will not go back into any drive gear unless the engine is switched off & re-started.all gears can be selected when the engine is not running!thanks for any info.

Car details
Car: Alfa Romeo 147
Variant: 2.0 selespeed
Model Year: 2002
Category: Gearbox & Clutch
Replies and Fixes
Avatar
Witty
Top Fixer
750 points

Sep 20, 2012 (8 years ago)
Could be a faulty selection sensor...

This problem is archived

If you're having a similar problem please click below to re-post this problem, you can then customise it to suit your situation.


Options for fixing the problem

Fix the problem yourself

If you need parts to do the job head over to Euro Car Parts to find the parts you need.

  • Free UK Delivery
  • 365 Day Returns
  • Free Click and Collect
Find a Local Mechanic

Use our AutoInsider Find A Specialist search, find garages and mobile mechanics near you.

Simply enter your postcode, select the required specialist areas and view your results.


AutoInsider AI Robot picture

You might find these links to parts and similar problems helpful in solving this problem.
AIBot

Helpful & Related Links
Recalls
Click to see a list of Alfa Romeo 147 Recalls
More Problems
See more Alfa Romeo 147 Problems
Having a problem with your Alfa Romeo 147?

Tell us about your 147 problem

On Social Media