2004 Alfa Romeo 156 1.9JTD Veloce M-Jet
Blowing Noise

Avatar
Langers
Driver
1 points

Problem added: Jul 15, 2008 (12 years ago)
Have just drove to town and back at lunchtime, car was fine on the way, on way back started to get a bit of a blowing noise from the rear of the engine bay when over 3000 rpm, theres no loss in power or anything like that sounds like a loose pipe.

could this be the pipe to the turbo? there is no loss in power just a slight hissing sound when revved.

Car details
Car: Alfa Romeo 156
Variant: 1.9JTD Veloce M-Jet
Model Year: 2004
Category: Leaks & Noises
Replies and Fixes
Avatar
mr suzuki
Top Fixer
694 points

Jul 18, 2008 (12 years ago)
has your 156 got a boost gauge on dash is it reading normally it has a vacc pipe running to it that may have a small split or check all vacc pipes for leaks
Post a reply
Please login to reply.

Options for fixing the problem

Fix the problem yourself

If you need parts to do the job head over to Euro Car Parts to find the parts you need.

  • Free UK Delivery
  • 365 Day Returns
  • Free Click and Collect
Find a Local Mechanic

Use our AutoInsider Find A Specialist search, find garages and mobile mechanics near you.

Simply enter your postcode, select the required specialist areas and view your results.


AutoInsider AI Robot picture

You might find these links to parts and similar problems helpful in solving this problem.
AIBot

Helpful & Related Links
Recalls
Click to see a list of Alfa Romeo 156 Recalls
More Problems
See more Alfa Romeo 156 Problems
Having a problem with your Alfa Romeo 156?

Tell us about your 156 problem

News & Updates
Win £50 every month by answering problems
Are you a mechanic or handy with car repairs?

Need an MOT after lockdown?
Find your nearest MOT Test Centre

Volvo Seat Belt Recall
Affects S60CC, V60CC, S60, XC60, V60, XC70, V70 and S80

On Social Media