2009 Vauxhall Insignia Problems

Problems and faults with the 2009 model year Vauxhall Insignia
Search Insignia Problems

Select Model Year
Latest 2009 Vauxhall Insignia Problems
3
responses
CLUTCH SLAVE CYLINDER

FITTED 2 DIFFERENT MAKES OF SLAVE CYLINDER BOTH HAVE LEAKED

2009 Vauxhall Insignia 1.8 PETROL
Posted: Aug 17, 2021
1
response
5
responses
Limp mode

Had it put on diagnostic to clear fault went fetched it and a hour into driving limp mode again

2009 Vauxhall Insignia 1.6 turbo
Posted: Jun 21, 2021
3
responses
Main beam not working

All my lights work except main beam..blue light shows they are but actually they arent.checked fuses etc still no joy oh they are bi xexon any help plz pulling my hair out now

2009 Vauxhall Insignia 2ltr cdti
Posted: May 23, 2021
5
responses
Vauxhall insignia 09 1.8 engine rattle on start up or left for a bit

Rattle on start up or if left for a bit

2009 Vauxhall Insignia 1.8
Posted: Feb 14, 2021
1
response
Information screen

Information screen blank and permanently light red even when ignition is turned off

2009 Vauxhall Insignia 2.0cdti
Posted: May 25, 2020
1
response
Rear wiper, washer, demister

Rear wiper, washer , demister not working and door light sign stays on !

2009 Vauxhall Insignia 1.8 exclusiv petrol
Posted: Dec 7, 2019
4
responses
ECU

Hi all , I have an ECU problem. The error code read P0016/17 camb sensors. So had new sensors fitted new cambelt fitted, water pump and still have ECU problem . It started when I had a new part of ...

2009 Vauxhall Insignia SRI 1.8I
Posted: Jun 14, 2019
1
response
Engine management light coming on

occasionally the management light comes on and when i plug in my code reader it informs me that air/fuel mixture is( Lean bank 1 ) I can delete this message and it can be a a few days later when the s...

2009 Vauxhall Insignia 1.8 exclusive 5 door hatch
Posted: May 23, 2018
2
responses
ALMOST INSTANT COOLANT LEAK

Hi, I fill my coolant tank and it’s pretty much empty a mile down the road but doesn’t empty when the engine is off, I know you guys probably can’t tell me my exact problem but what are the poss...

2009 Vauxhall Insignia 1.8 SRI Petrol
Posted: Nov 12, 2017
2
responses
Won't start after replacing cam shaft sensor

Car wouldn't start, put on computer & can shaft sensor came up as fault, put new sensor in but still won't start what else can it be

2009 Vauxhall Insignia 2.0 cdti
Posted: Sep 8, 2017
7
responses
Car won't start

have replaced battery. have replaced ECU. Dashboard fully lit and radio comes on. Will not start or even turn over. Not even a 'clicking' sound. Have spent over £400 already and still no further for...

2009 Vauxhall Insignia 2.0 cdti
Posted: Aug 19, 2017
2
responses
Reverse light and rear left indicator not working

Recently my reverse light and rear left indicator light have stopped working and I recently had it plugged in and the faults cum up where rear fog lamp control circuit open back up lamp control circu...

2009 Vauxhall Insignia Sri cdti
Posted: Jul 28, 2017
2
responses
Stutter ?

Hi could any one help with a suggestion on problem on my car please , when I set off it's seems to judder then picks up only a second or so this happens in first and second then it's fine also the odd...

2009 Vauxhall Insignia 1.8 exclusive nav
Posted: Apr 2, 2017
1
response
Flat battery

After 4 days of the car not been started the battery has gone flat. I have had a new battery fitted and the alternater checked out OK. It has now done this 3 times since Christmas. I have had a vauxha...

2009 Vauxhall Insignia 2.0l cdti160
Posted: Mar 2, 2017
1
response
Can't open the boot

Pressing the button doesn't work

2009 Vauxhall Insignia 2lt exclusive 5door hatch
Posted: Feb 18, 2017
2
responses
Driver SeatBelt Indicator not workink

When you turn the ignition you don't get a picture of a seat belt illuminate. when you drive the car without driver seatbelt on the car use to make a beeping sound however this is not happening anymor...

2009 Vauxhall Insignia SRI
Posted: Feb 8, 2017
2
responses
Usb and cd stopped working

Hi, 3 days ago my usb and cd stopped working for no reason, the cd player is taking the cd in and out and it's saying in the screen (cdin) but won't work and the usb is not responding at all. The au...

2009 Vauxhall Insignia 1.8 sri
Posted: Jan 25, 2017
3
responses
Car won't start

Hi I went to take the car of the drive and as I was reversing of it cut out and would not start again, The fuel pump is working I have changed the fuel filter I had the injectors tested with th...

2009 Vauxhall Insignia 2.0cdti
Posted: Oct 26, 2016
1
response
Wont start

information came up dpf was full so i did what my hand book told me to do it then went in to limp mode so i took it for a half hour drive and kept the revs at 2,500 rpm to clear it as i have done befo...

2009 Vauxhall Insignia 2.0 sri nav
Posted: Sep 6, 2016
Having a problem with your Vauxhall Insignia?

Tell us about your Insignia problem

On Social Media