2003 Vauxhall Zafira 2ltr diesal Lack of power

Avatar
big gord

Profile
Problem added: Nov 27, 2013 (6 years ago)
hi all i left my lights on so bumped started the symble car with spanner came on reves up ok it seems that turbo is not kicking in noticed the symble went out but when come to halt back on any help thank in advance ps the car was runing fine before that

Car details
Car: Vauxhall Zafira
Variant: 2ltr diesal
Model Year: 2003
Category: Running Rough, Starting & Power Loss

Recalls: Vauxhall Zafira Recalls
More: Vauxhall Zafira Problems
Parts mentioned in this problem
Replies and solutions
Avatar
whittingehame
Fixes: 12,398
Profile
Nov 27, 2013 (6 years ago)
First thing I would do is fully charge battery rather than relying on alternator to replenish charge .
Avatar
midnightcaller
Fixes: 16
Profile
Oct 12, 2014 (5 years ago)
possibly an EGR (exhaust gas recirculation) valve issue. could possibly need a good clean or replacing. may be a vacuum hose split on the EGR or the vacuum control valve which is also a common failure.
Post a reply
Please login to reply
Planning on fixing the problem yourself?

If you need parts to do the job head over to Euro Car Parts to find the parts you need.

  • Free UK Delivery
  • 365 Day Returns
  • Free Click and Collect
Fix your Zafira problem

Get answers from experts and owners

Add your problem now, it's quick and easy.

Get Answers & Solutions
More 2003 Zafira problems
Find your nearest
Diagnostics App

Identify problem parts

Try it now
On Social Media