Lack of power
2003 Vauxhall Zafira 2ltr diesal

Avatar
big gord
Driver
1 points

Problem added: Nov 27, 2013 (7 years ago)
hi all i left my lights on so bumped started the symble car with spanner came on reves up ok it seems that turbo is not kicking in noticed the symble went out but when come to halt back on any help thank in advance ps the car was runing fine before that

Car details
Car: Vauxhall Zafira
Variant: 2ltr diesal
Model Year: 2003
Category: Running Rough, Starting & Power Loss
Replies and Fixes
Avatar
whittingehame
Legend
20,108 points

Nov 27, 2013 (7 years ago)
First thing I would do is fully charge battery rather than relying on alternator to replenish charge .
Avatar
midnightcaller
Driver
16 points

Oct 12, 2014 (6 years ago)
possibly an EGR (exhaust gas recirculation) valve issue. could possibly need a good clean or replacing. may be a vacuum hose split on the EGR or the vacuum control valve which is also a common failure.

This problem is archived

If you're having a similar problem please click below to re-post this problem, you can then customise it to suit your situation.


Options for fixing the problem

Fix the problem yourself

If you need parts to do the job head over to Euro Car Parts to find the parts you need.

  • Free UK Delivery
  • 365 Day Returns
  • Free Click and Collect
Find a Local Mechanic

Use our AutoInsider Find A Specialist search, find garages and mobile mechanics near you.

Simply enter your postcode, select the required specialist areas and view your results.


Having a problem with your Vauxhall Zafira?

Tell us about your Zafira problem

On Social Media