Temp Gauge not working
2006 Vauxhall Meriva 1.6

Avatar
dps4287
Driver
1 points

Problem added: Dec 5, 2009 (11 years ago)
Hi Guys, the temp gauge on my missus meriva has stopped working. There is heat for hot air from the fans in the car although they seem to take ages to warm up. Also I've noticed the petrol consumption has gone up a lot. Is this likely to be a sensor or the thermostat? If you can help and advise where I can find the sensor/therm if that what it is ?

Cheers for your help

Darren.

Car details
Car: Vauxhall Meriva
Variant: 1.6
Model Year: 2006
Category: Electrics, ECU, Warnings & Lights
Replies and Fixes
Avatar
chippy28
Driver
4 points

Dec 8, 2009 (11 years ago)
hi... the therm should be on the radiater itself... it may need changing or you could wire a switch to the fan its self to turn it on and of yourself from inside the car... can be fidly...

This problem is archived

If you're having a similar problem please click below to re-post this problem, you can then customise it to suit your situation.


Options for fixing the problem

Fix the problem yourself

If you need parts to do the job head over to Euro Car Parts to find the parts you need.

  • Free UK Delivery
  • 365 Day Returns
  • Free Click and Collect
Find a Local Mechanic

Use our AutoInsider Find A Specialist search, find garages and mobile mechanics near you.

Simply enter your postcode, select the required specialist areas and view your results.


AutoInsider AI Robot picture

You might find these links to parts and similar problems helpful in solving this problem.
AIBot

Having a problem with your Vauxhall Meriva?

Tell us about your Meriva problem