New Glow Plugs - Van very slow to Start - 2009 Combo 1.3CDTi

2009 Vauxhall Combo 1.3CDTi
Car: Vauxhall Combo
Year: 2009
Variant: 1.3CDTi
Categories: Engine & DrivetrainElectrics, ECU, Warnings & Lights
I have just replaced the Glow Plugs in the Van as it was taking longer and longer to start.

Now it is next to impossible to start from Cold. This a.m. I probably heated the Glow Plugs circa 20 times before it started.

Any ideas what can be wrong - no Fault showing currently.
Problem added: Mar 1, 2024 (1 month ago)
You verified all glow plugs replaced are operating ?
Answered Mar 1, 2024 (1 month ago)
Original Bosch came out (134K Miles) spurious make went in.

Yes they are getting power - Engine turning over but not starting.

Diagnostic tool showing Ambient Temperature at -22 but the Temperature is 7 degrees C as per the Dash - Dash is correct.
Answered Mar 1, 2024 (1 month ago)
Replace / repair Ambient Temperature sensor or wiring if needed
Answered Mar 1, 2024 (1 month ago)
It seems the Fuel Pump went at the same time - Pump replaced - Van now starting as normal.

Nothing done re the Ambient Temperature reading - Console showing the correct Temperature reading.
Answered Mar 14, 2024 (1 month ago)

Post a reply

Helpful & Related Pages on AutoInsider

Parts referenced on this page
More problems with the 2009 model year Vauxhall Combo

We have 8 problems and solutions in our database for this model year of the car.

View all Vauxhall Combo Problems

Similar problems
Cold Starting
1999 Ford Fiesta 1.8D
Car has problem starting when cold
1999 Vauxhall Omega 2.0dti gls
3 times glow plug
2004 Citroen Berlingo 1,9
Cold start
2004 Citroen Berlingo
Starting from cold
2000 Rover 45 2.0 turbo diesel