2005 Peugeot 407 EW10 Manual Engine management, Depollution, main beam bulbs and ESP/ASR system faulty

Avatar
Chacha

Profile
Problem added: Jun 18, 2016 (4 years ago)
My car suddenly developed a loss of power despite engine still runs. It jerks and sound goes high on its own and when trying to accelerate it, I got no response. Dashboard clocks and fuel guage goes off and comes on. Electric windows cant go up nor down. Even when it picks most times, it goes off on its own. Need to shut down and start again before it can gain power but after a while, it losses it again.
Please, what do i do.

Car details
Car: Peugeot 407
Variant: EW10 Manual
Model Year: 2005
Category: Running Rough, Starting & Power Loss

Recalls: Peugeot 407 Recalls
More: Peugeot 407 Problems
Replies and solutions
Avatar
whittingehame
Fixes: 12,418
Profile
Jun 19, 2016 (4 years ago)
Sounds as if the car is going in to limp mode .May be more than one fault , possibly instrument cluster fault and others . Better to get it scanned and see what shows rather than guess .
Post a reply
Please login to reply
Planning on fixing the problem yourself?

If you need parts to do the job head over to Euro Car Parts to find the parts you need.

  • Free UK Delivery
  • 365 Day Returns
  • Free Click and Collect
Fix your 407 problem

Get answers from experts and owners

Add your problem now, it's quick and easy.

Get Answers & Solutions
More 2005 407 problems
Find your nearest
Diagnostics App

Identify problem parts

Try it now
On Social Media