No power at fuses
2005 Peugeot 206

Avatar
hoohgoo
Driver
3 points

Problem added: Dec 21, 2018 (2 years ago)
Hi my 206 came up with a anti pollution fault running super rough and wouldn't go over 3000 revs tried to drive home car stalled came up with immobilizer fault for a minute then saying eco mode so now car wont start there is no power at fuses under the bonnet I have changed the fuse box with no joy HELP......

Car details
Car: Peugeot 206
Model Year: 2005
Category: Electrics, ECU, Warnings & Lights
Replies and Fixes
Avatar
1/4drive
Legend
1,892 points

Dec 22, 2018 (2 years ago)
Check the battery clamps/cables,
give them a twist on the battery
they shouldn't be able to move.
and check the earth wire where it bolts on down by the gearbox.
Avatar
hoohgoo
Driver
3 points

Dec 22, 2018 (2 years ago)
How do you get to earth cable from bonnet or under car
Avatar
hoohgoo
Driver
3 points

Dec 22, 2018 (2 years ago)
Found it clean you think alternator earth would cause it?
Avatar
1/4drive
Legend
1,892 points

Dec 22, 2018 (2 years ago)
any ground fault can cause faults.
your just going to have to be systematic and check all power and grounds under the bonnet.
a single jump lead can help.
battery neg to chassis for example,
if there is any ground fault in to battery to chassis this make them light
if I recall there's a suspect ground wire that runs to the passenger chassis leg

This problem is archived

If you're having a similar problem please click below to re-post this problem, you can then customise it to suit your situation.


Options for fixing the problem

Fix the problem yourself

If you need parts to do the job head over to Euro Car Parts to find the parts you need.

  • Free UK Delivery
  • 365 Day Returns
  • Free Click and Collect
Find a Local Mechanic

Use our AutoInsider Find A Specialist search, find garages and mobile mechanics near you.

Simply enter your postcode, select the required specialist areas and view your results.


Having a problem with your Peugeot 206?

Tell us about your 206 problem