2003 Peugeot 206 - Car turns but doesn't fire !!!! HELP PLEASE !!!!!

206 206 SW 1.4 Petrol Problem
The Problem
Avatar
gazO
Fixes: 8
Profile
Car turns but doesn't fire !!!! HELP PLEASE !!!!!
Aug 10, 2015 (4 years ago)
I have a Peugeot 206sw 1.4 petrol. Took it to work the other week and it was running fine. However come home time I got in the car to start it and it just turned over and didn't fire.
A friend carried out a diagnostics check on the car and it showed a fault with the crankshaft sensor and coil pack.

This is what I have done to it so far !!! But it's still the same !!!

Replaced the battery in the key fob
Reset the BSI
Checked all Fuses
Installed a new crank shaft sensor
Installed a new coil pack
Checked and cleaned the spark plugs

starting to lose patience now scratching my head would be most grateful for any help PLEASE !!!!!!

Car: Peugeot 206
Variant: 206 SW 1.4 Petrol
Year: 2003
Category: Running Rough, Starting & Power Loss
Recalls: Peugeot 206 Recalls
More: Peugeot 206 Problems
Ad
Avatar
whittingehame
Fixes: 12,188
Profile
Aug 10, 2015 (4 years ago)
Checked the timing belt is o.k ? Checked to see if getting spark and fuel ? Check wiring / connection at crank sensor .
Avatar
gazO
Fixes: 8
Profile
Aug 10, 2015 (4 years ago)
Thanks for replying, yes I've checked the wiring to the crankshaft sensor seems OK. When you turn the starter motor over the low pressure fuel pump in the tank does not run and there is no spark as we rigged the coil pack up to a spark tester. However when we connected the fuel pump up to a 12v battery independently it works fine. Could it be an immobiliser issue or a bad earth????
Avatar
paulieone
Fixes: 1,666
Profile
Aug 10, 2015 (4 years ago)
is the key being recognised?Put key in ignition and open door it should beep.
Avatar
gazO
Fixes: 8
Profile
Aug 10, 2015 (4 years ago)
Yes on opening the door then is a continuous beeping noise for about 6-8 seconds with the key in the ignition.
Avatar
paulieone
Fixes: 1,666
Profile
Aug 10, 2015 (4 years ago)
That generally rules out a problem with the key,If you have replaced the parts you have mentioned then you either have a problem with the wiring or the faults need to be cleared from ecu before it will run
Avatar
1/4drive
Fixes: 1,862
Profile
Aug 11, 2015 (4 years ago)
Get your friend back and check the RPM signal on his scanner.
Live data should show a rpm on crank,
and you need to establish IF there is any crank signal at the ECU.
Avatar
paulieone
Fixes: 1,666
Profile
Aug 11, 2015 (4 years ago)
if you replaced the coil you should have replaced the plugs at the same time.
Avatar
gazO
Fixes: 8
Profile
Aug 12, 2015 (4 years ago)
FIXED !!!!!! Bad earth connection coming from ECU !!! Sorted Many Thanks for all the suggestions.
Avatar
paulieone
Fixes: 1,666
Profile
Aug 12, 2015 (4 years ago)
thanks for returning the information
Post a reply
Please login to reply

More 2003 206 problems
Can't find a solution to your problem?
Planning on fixing the problem yourself?

If you need parts to do the job head over to Euro Car Parts to find the parts you need.

  • Free UK Delivery
  • 365 Day Returns
  • Free Click and Collect