Fan not working
2010 Mitsubishi L200 Warrior

Avatar
Darren Rendall
Driver
1 points

Problem added: Nov 5, 2018 (2 years ago)
Fan won’t work, fuses are all fine and there’s power going to the fan, fan still works fine when plugged into battery, must be a problem with the earth from the fan ??
Car: Mitsubishi L200
Variant: Warrior
Model Year: 2010
Category: Electrics, ECU, Warnings & Lights
Replies and Fixes
Avatar
1/4drive
Legend
1,892 points

Nov 6, 2018 (2 years ago)
Could be,
though relays often controlled via ECU.
Try a jumper ground to the fan motor.
Or try a 12 V test bulb connected to battery pos+ and other end to the fan ground plug pin.

This problem is archived

If you're having a similar problem please click below to re-post this problem, you can then customise it to suit your situation.

What to do next?

Fix the problem yourself...

If you need parts to do the job head over to Euro Car Parts to find the parts you need.

  • Free UK Delivery
  • 365 Day Returns
  • Free Click and Collect
or Find a Local Mechanic

Use our AutoInsider Find A Specialist search, find garages and mobile mechanics near you.

Simply enter your postcode, select the required specialist areas and view your results.

Helpful & Related Pages on AutoInsider
Generated by AutoInsider AIBot
AutoInsider AI Robot picture
Parts mentioned on this page
Battery
Click to read more about the part & problem symptoms

Recalls
Click to see a list of Mitsubishi L200 Recalls
More Problems
See more Mitsubishi L200 Problems
barbarian Cab heater blowing cold air
SRS Airbag Light on
Having a problem with your Mitsubishi L200?

Tell us about your L200 problem

On Social Media