2006 Vauxhall Zafira 1.6 life Car Spanner light on start up but clears when engine warmed up

Avatar
DeclanBuc1966
Fixes: 1
Profile
Problem added: Jul 7, 2016 (4 years ago)
About 2 weeks after having the car serviced I noticed the car spanner light(static no flashing) appearing on starting up the engine. If I run the car for 10 minutes then turn off the engine and start it again the spanner light disappears. With the spanner light on the car drives normally and can rev above 3000 revs without issue so not in Limp Home mode. Checking various forums it suggests either the MAF or the LAMBDA sensors need changing? May wait until the next Zafira recall in August for this to be checked by Vauxhall. Unless someone knows what this may be? The car drives normally with or without the spanner light.

Car details
Car: Vauxhall Zafira
Variant: 1.6 life
Model Year: 2006
Category: Electrics, ECU, Warnings & Lights

Recalls: Vauxhall Zafira Recalls
More: Vauxhall Zafira Problems
Parts mentioned in this problem
Replies and solutions
Avatar
whittingehame
Fixes: 12,412
Profile
Jul 7, 2016 (4 years ago)
No point in guessing , you need to scan it and see what codes are stored .
Avatar
1/4drive
Fixes: 1,862
Profile
Jul 7, 2016 (4 years ago)
Well I'd suggest staying away from those forums,
the Lambda or o2 as it's also known doesn't even have a function or any effect on the engine until it heats up.
The sensor even has an internal heater to speed the heating up process.
So no way could it be switching on any warning light.
The only thing I can see from you "forum" advice is how to spend money needlessly.
As advised get it scanned.
Avatar
Derbyshire
Fixes: 223
Profile
Jul 7, 2016 (4 years ago)
As advised best getting it scanned or it's gess work. You can buy a code reader online for a small price and well worth the money.
Avatar
Derbyshire
Fixes: 223
Profile
Jul 7, 2016 (4 years ago)
As advised best getting it scanned or it's gess work. You can buy a code reader online for a small price and well worth the money.
Avatar
whittingehame
Fixes: 12,412
Profile
Jul 7, 2016 (4 years ago)
If limited mechanical knowledge , unable to interpret the fault codes . buying scanner a total waste of time and money as many have found out .
Avatar
DeclanBuc1966
Fixes: 1
Profile
Oct 6, 2016 (3 years ago)
Furrther update. Vauxhall scanned the car for error codes when doing the latest aircon recall. Error P1113 which relates to a sensor in the exhaust manifold. It is very common on Zafira Bs. Now for the bad news. You have to replace the full exhaust manifold including inbuilt sensor.The Vauxhall dealers will take £850 off you for the priviedge! Other options would be take the manifold off your self clean it and reassemble OR buy one off ebay for around £160 and ask a good car mechanic to replace it for you!. I'm just living with the spanner light on the dash for now as the car still drives fine and had 44mpg on a long run recently so no real adverse affects so far.
Post a reply
Please login to reply
Planning on fixing the problem yourself?

If you need parts to do the job head over to Euro Car Parts to find the parts you need.

  • Free UK Delivery
  • 365 Day Returns
  • Free Click and Collect
Fix your Zafira problem

Get answers from experts and owners

Add your problem now, it's quick and easy.

Get Answers & Solutions
More 2006 Zafira problems
Find your nearest
Recent Car Problems
Diagnostics App

Identify problem parts

Try it now
On Social Media