2003 Vauxhall Zafira 1.8 auto petrol Start car in morning but idles badly and wont pull away until i let it run for a while

Problem added: Nov 27, 2013 (6 years ago)
i start my car in the morning revs high on start up for a few seconds ticks over a bit
uneven the problem strts when i put my car in drive and use the excellorater to pull away the jumps and is slow to pick its as if the engine is starved of petrol.
i was wondering if its my idle sensor but im not getting any engine management light

Car details
Car: Vauxhall Zafira
Variant: 1.8 auto petrol
Model Year: 2003
Category: Running Rough, Starting & Power Loss

Recalls: Vauxhall Zafira Recalls
More: Vauxhall Zafira Problems
Replies and fixes
Avatar
whittingehame
Fixes: 12,508
Nov 27, 2013 (6 years ago)
Could try replacing engine coolant temp sensor which sends signal via the ecu to control cold start/fueling
Post a reply
Please login to reply
Planning on fixing the problem yourself?

If you need parts to do the job head over to Euro Car Parts to find the parts you need.

  • Free UK Delivery
  • 365 Day Returns
  • Free Click and Collect
Fix your Zafira problem

Add your problem now, it's quick and easy

Post a Problem
More 2003 Zafira problems
News & Updates
Need an MOT after lockdown?
Find your nearest MOT Test Centre

Volvo Seat Belt Recall
Affects S60CC, V60CC, S60, XC60, V60, XC70, V70 and S80

AutoInsider recall database updated
Recent recalls for Volvo, Audi and Porsche

Find your nearest
Diagnostics App

Identify problem parts

Try it now
On Social Media