2010 Vauxhall Meriva 1.4
Erly morning it takes along time to start and when it starts it run normal temp gage reads 90 but only takes 2 mins to get there

Avatar
raymond price
Driver
1 points

Problem added: Nov 9, 2020 (3 weeks ago)
i took my car to a garage he put the tester on and found no faults at all when he removed the plugs thay were all dry but sparking well it seems as fule is not getting in . when it runs and turn it off it will start just like normal even when left for a few hours. i only have this problem when its cold as if its not alowing the choke to come on to draw the fule

Car details
Car: Vauxhall Meriva
Variant: 1.4
Model Year: 2010
Replies and Fixes
Avatar
whittingehame
Legend
15,967 points

Nov 9, 2020 (3 weeks ago) Edited on Nov 9, 2020 (3 weeks ago)
Try changing the engine coolant temp sensor . This sends info to the ECU to richen fuel mixture for cold start , like old choke . Could also explain temp gauge .
Post a reply
Please login to reply.

Options for fixing the problem

Fix the problem yourself

If you need parts to do the job head over to Euro Car Parts to find the parts you need.

  • Free UK Delivery
  • 365 Day Returns
  • Free Click and Collect
Find a Local Mechanic

Use our AutoInsider Find A Specialist search, find garages and mobile mechanics near you.

Simply enter your postcode, select the required specialist areas and view your results.


AutoInsider AI Robot picture

You might find these links to parts and similar problems helpful in solving this problem.
AIBot

Helpful & Related Links
Recalls
Click to see a list of Vauxhall Meriva Recalls
More Problems
See more Vauxhall Meriva Problems
Having a problem with your Vauxhall Meriva?

Tell us about your Meriva problem

News & Updates
Win £50 every month by answering problems
Are you a mechanic or handy with car repairs?

Need an MOT after lockdown?
Find your nearest MOT Test Centre

Volvo Seat Belt Recall
Affects S60CC, V60CC, S60, XC60, V60, XC70, V70 and S80

On Social Media