Vauxhall Insignia Problems & Fixes

Search 314 real owner problems with the Vauxhall Insignia
Search Insignia Problems

1
response
Auto gearbox issue

When put in park, a warning comes up saying “shift to park” despite it already being in park?? Takes a few gearstick movements for it to stop giving the warning. Anything I can do it is it back to...

2019 1.5T SXI VX LINE AUTO
Posted: Oct 9, 2021
1
response
Parked up, no problems whatsoever. Came out of shop, no power.

Parked up, came out of store. Put shipping in car, locked doors and went to ATM. Returned to car and car would not start. Power appears dead.

2013 1.8
Posted: Oct 3, 2021
1
response
Poor acceleration

When you accelerate it hops when under low revs

2010 1.8i
Posted: Sep 29, 2021
1
response
Running/dipped beam bulb not working when I start the car

When I turn on the ignition, the running lights all work perfectly, but as soon as I start the car an error message comes up saying that the running light and dipped beam bulb on the driver's side are...

2014 2.0 cdti
Posted: Sep 29, 2021
2
responses
Engine bay sound

Have an unsettling sound like wind through a pipe on accelerating and decelerating. (sputters a bit when decelerating). Sound not there when idling and when the clutch is pressed down/disengaged. Can...

2010 1.8 petrol
Posted: Sep 26, 2021
3
responses
Major issues

Battery was draining frequently and then would be fine for a couple of weeks then dead again, cleaned all earth terminals on body that I could see, car started first time no issues, unfortunately I or...

2012 2.0 ltr cdti
Posted: Sep 3, 2021
1
response
Code 3

Had the expansion tank replaced and coolant on max. Still grtting code 3 when enhine is vold or when it has been used amd is hot. The coolant is not leaking now. Any suggedtions

2012 1.8 petrol
Posted: Sep 2, 2021
1
response
Horn not working

My horn has just stopped working. Have checked both fuses and are still in tact . Anyone any ideas thanks .

2010 2l tdi sri
Posted: Aug 29, 2021
11
responses
Gearbox gear change

I had the bearings changed by a transmission specialist recently due to a whining noise. When the box was re-installed, it refuses to engage 5th, 6th and reverse gears. The gear linkage was checked ...

2013 SRI 1.8 petrol
Posted: Aug 25, 2021
1
response
Navi 600 gone dead after upgrading to 900

Update my navi 600 to navi 900 to better the maps but now nothing showing like no power but the screen do flicks on startup and no seat belt noise ect can I sort this out or can I bye a navi500 system...

2013 2.0 cdti
Posted: Aug 21, 2021
3
responses
CLUTCH SLAVE CYLINDER

FITTED 2 DIFFERENT MAKES OF SLAVE CYLINDER BOTH HAVE LEAKED

2009 1.8 PETROL
Posted: Aug 17, 2021
1
response
Oil leak issues

Ive been having an oil leak from front left section of engine block. Thought it might have been the cap but replaced that and still prominent. Wondering what else it could be.

2012 1.4 petrol tourer
Posted: Aug 16, 2021
Having a problem with your Vauxhall Insignia?

Tell us about your Insignia problem

Select Model Year
Insignia Part Problems
On Social Media