2012 Vauxhall Corsa corsa 1.4 100ps
Lags when cold

Avatar
iosif1961
Driver
2 points

Problem added: Feb 13, 2017 (3 years ago)
when i start in the morning starts ok but when i drive it have little power and i have to increase the revs..when the engine warms up all is fine in acceleration and cruising!

Car details
Car: Vauxhall Corsa
Variant: corsa 1.4 100ps
Model Year: 2012
Category: Running Rough, Starting & Power Loss
Replies and Fixes
Avatar
whittingehame
Legend
14,861 points

Feb 13, 2017 (3 years ago)
Possibly engine coolant temp sensor ?
Avatar
iosif1961
Driver
2 points

Feb 14, 2017 (3 years ago)
But when i switch on the secret menu to watch the temperature its rising ok till 107°c where the fan switches on..
Post a reply
Please login to reply.
Planning on fixing a problem yourself?

If you need parts to do the job head over to Euro Car Parts to find the parts you need.

  • Free UK Delivery
  • 365 Day Returns
  • Free Click and Collect
Having a problem with your Vauxhall Corsa?

Tell us about your Corsa problem

AutoInsider AI Robot picture

You might find these links helpful in solving this problem.
AIBot

Helpful Links
Recalls
Click to see a list of Vauxhall Corsa Recalls
More Problems
See more Vauxhall Corsa Problems
More 2012 Corsa problems
News & Updates
Need an MOT after lockdown?
Find your nearest MOT Test Centre

Volvo Seat Belt Recall
Affects S60CC, V60CC, S60, XC60, V60, XC70, V70 and S80

AutoInsider recall database updated
Recent recalls for Volvo, Audi and Porsche

Find your nearest
Diagnostics App

Identify problem parts

Try it now
On Social Media