2006 Vauxhall Combo 1.3 CDTI
Throttle not revving engine

Avatar
Collette Cooper
Driver
1 points

Problem added: Apr 30, 2020 (5 months ago)
2 issues...
Van wouldn't start so disconnected the MAF sensor, van started but when we reconnected it the engine cut out
When pressing the accelerator pedal, the engine doesn't rev. This has been an intermittent fault for a few weeks, whilst driving the engine would not accelerate straight away but then seemed to correct itself. When we got the engine running as above, the accelerator didn't work at all

Car details
Car: Vauxhall Combo
Variant: 1.3 CDTI
Model Year: 2006
Category: Running Rough, Starting & Power Loss
Replies and Fixes
Avatar
whittingehame
Legend
14,861 points

Apr 30, 2020 (4 months ago)
Could be the throttle position sensor / throttle pedal .
Post a reply
Please login to reply.
Planning on fixing a problem yourself?

If you need parts to do the job head over to Euro Car Parts to find the parts you need.

  • Free UK Delivery
  • 365 Day Returns
  • Free Click and Collect
Having a problem with your Vauxhall Combo?

Tell us about your Combo problem

AutoInsider AI Robot picture

You might find these links helpful in solving this problem.
AIBot

News & Updates
Need an MOT after lockdown?
Find your nearest MOT Test Centre

Volvo Seat Belt Recall
Affects S60CC, V60CC, S60, XC60, V60, XC70, V70 and S80

AutoInsider recall database updated
Recent recalls for Volvo, Audi and Porsche

Find your nearest
Diagnostics App

Identify problem parts

Try it now
On Social Media