2011 Vauxhall Combo - Limp mode keeps coming on in rain loosing turbo and acelarator somtimes

Combo 1700 1.3 cdti se Problem
The Problem
Avatar
irving143
Fixes: 1
Profile
Limp mode keeps coming on in rain loosing turbo and acelarator somtimes
Dec 18, 2014 (5 years ago)
my combo keeps going into limp mode in rain only in rain loosing turbo and acelarator is playing up , have already replaced acelarator peddal still have the problem was thinking it is electical but read a post on here from earlier on same problem you think it may be turbo issues has any body fixed this problem ?????

Car: Vauxhall Combo
Variant: 1700 1.3 cdti se
Year: 2011
Category: Engine & Drivetrain
Recalls: Vauxhall Combo Recalls
More: Vauxhall Combo Problems
Ad
Avatar
whittingehame
Fixes: 12,195
Profile
Dec 19, 2014 (5 years ago)
Get it scanned and see what fault codes shown .
Avatar
irving143
Fixes: 1
Profile
Dec 19, 2014 (5 years ago)
had it scanned its says it was the acelarator peddal , replaced the peddal problem still there , starting to think its the ecu
Avatar
whittingehame
Fixes: 12,195
Profile
Dec 22, 2014 (5 years ago)
Check the wiring / plug at pedal and ECU .
Avatar
Pete l
Fixes: 2
Profile
Nov 28, 2015 (4 years ago)
Have you had a look at this similar problem:

This message was auto-generated based on a user suggestion.
Post a reply
Please login to reply

Can't find a solution to your problem?
Planning on fixing the problem yourself?

If you need parts to do the job head over to Euro Car Parts to find the parts you need.

  • Free UK Delivery
  • 365 Day Returns
  • Free Click and Collect