EML on, have tried EVERYTHING!!!

2000 Vauxhall Astra Problem

The Problem

Avatar Ian the drummer
Joined: 7 years ago | Fixes: 1 | Profile
About

Hi all, this seems like a common Astra problem but I need some help please.
Around 12 months ago the EML came on throwing up fault codes 0110 and 0420. I had already changed the egr valve, coil pack, plugs and cleaned the throttle body, changed fuel filter before getting the codes and then changed the air intake temp sensor.
Basically when driving over 30mph the car starts to kangaroo and dies as soon as the clutch is dipped, it's then difficult to re-start for a few minutes. The fault codes point to a problem with either the cat or lambda sensors so i changed the sensors with no change. I then left the rear sensor unplugged and it ran 100%! I am now finding that the fuel gauge is reading incorrectly and actually rises gradually when driving at 70ish for more than a few minutes.. this only happens with the sensor plugged in. As for the fault being cat related, it passed the emissions test with flying colours with the sensor plugged in..
I'm at a total loss as to what to try next!!!!
Any help or advice would be much appreciated!
Cheers
Ian.


Car Vauxhall Astra
Variant 1.6 sxi
Model Year 2000
Category Electrics, ECU, Warnings & Lights

All Vauxhall Astra Problems

Solution

Avatar 1/4drive
Joined: 8 years ago | Fixes: 1,862 | Profile

Your diagnosis is wrong.
Go back,recheck.
Best guess is a wiring harness fault somewhere between the ecu and IAT.
Start checking voltages.

Social Media