4 wheel drive not working correctly
2015 Ssangyong Rexton 2.0L ELX, XDI

Avatar
Mark Hanson
Driver
1 points

Problem added: Feb 18, 2021 (1 week ago)
Pulled of road to let large lorry go past and engaged 4H as I pulled on but it didn't engage properly as I nearly go stuck. There appeared to be no drive to front wheels. Only one rear wheel spun. Lights came on, on dash to say engaged but I don't think it was.

Car details
Car: Ssangyong Rexton
Variant: 2.0L ELX, XDI
Model Year: 2015
Category: Engine & Drivetrain
Replies and Fixes
Avatar
whittingehame
Legend
17,486 points

Feb 18, 2021 (1 week ago)
Don't know much about the set up on that vehicle but do know they sometimes had problems with vac hoses to hubs . You would be better trying here for more info , sorry cant help much on this matter

https://www.ssangyongclub.co.uk/forum/index.php
Post a reply
Please login to reply.

Options for fixing the problem

Fix the problem yourself

If you need parts to do the job head over to Euro Car Parts to find the parts you need.

  • Free UK Delivery
  • 365 Day Returns
  • Free Click and Collect
Find a Local Mechanic

Use our AutoInsider Find A Specialist search, find garages and mobile mechanics near you.

Simply enter your postcode, select the required specialist areas and view your results.


AutoInsider AI Robot picture

You might find these links to parts and similar problems helpful in solving this problem.
AIBot

Helpful & Related Links
Recalls
Click to see a list of Ssangyong Rexton Recalls
More Problems
See more Ssangyong Rexton Problems
Having a problem with your Ssangyong Rexton?

Tell us about your Rexton problem