Antipolution fault
2004 Peugeot 307 2.0 hdi

Avatar
Robb08
Driver
1 points

Problem added: Jul 12, 2016 (4 years ago)
I have a Peugeot 307 2.0hdi. 54 plate. After having it serviced (full)., it lost power and displayed an antipolution fault. This has stayed on now and really struggles when hitting any incline and has lost acceleration. The engine light and fault sometimes disappears but always comes back after a couple of days. It is currently not displaying the fault but is stuttering at 1500-2000 rpm. I have took it to the garage a couple of times where they have tried a couple of things bit with no success. He now says he needs the car for a couple of days to lift up the "whole carriage" to get to the turbo sensor. Can anyone help?

Car details
Car: Peugeot 307
Variant: 2.0 hdi
Model Year: 2004
Category: Running Rough, Starting & Power Loss
Replies and Fixes
Avatar
1/4drive
Legend
1,892 points

Jul 12, 2016 (4 years ago)
Yeah the turbo is a pain to get at but if the MIL lamp is coming on the first thing I'd do is plug in a scanner.
And the only reliable scanner for these is Peugeot's own system Peugeot Planet.
So I'd suggest you look in the book for your nearest diesel injection specialist.

This problem is archived

If you're having a similar problem please click below to re-post this problem, you can then customise it to suit your situation.


Options for fixing the problem

Fix the problem yourself

If you need parts to do the job head over to Euro Car Parts to find the parts you need.

  • Free UK Delivery
  • 365 Day Returns
  • Free Click and Collect
Find a Local Mechanic

Use our AutoInsider Find A Specialist search, find garages and mobile mechanics near you.

Simply enter your postcode, select the required specialist areas and view your results.


Having a problem with your Peugeot 307?

Tell us about your 307 problem

On Social Media