2006 Mitsubishi L200 2.8 My temperature gauge andfuel gauge is not working properly

Avatar
bulletproof

Profile
Problem added: Dec 31, 2014 (5 years ago)
both gauges are not working properly and the problem developed together.

Car details
Car: Mitsubishi L200
Variant: 2.8
Model Year: 2006
Category: Electrics, ECU, Warnings & Lights

Recalls: Mitsubishi L200 Recalls
More: Mitsubishi L200 Problems
Replies and solutions
Avatar
1/4drive
Fixes: 1,862
Profile
Dec 31, 2014 (5 years ago)
I'm not 100% sure on this one,
and the manual is at work,
not where I am right now,
So going on memory these are old style and both gauges are fed by a voltage stabaliser,
idea being so as to "smooth" out voltage fluctuations and give a steady gauge read,
and when both gauges go then it's a good bet the stabeliser is shot.
At the moment best guess is it's at the back of the gauge cluster so that has to come out to get at it.
If I'm right that is?
I'll be back at workshop on Friday so I'll check the manual then and repost if nedded.
Avatar
1/4drive
Fixes: 1,862
Profile
Jan 1, 2015 (5 years ago)
Yeah.
there's a module on the back of the instrument cluster that feeds power to both gauges,
Post a reply
Please login to reply
Planning on fixing the problem yourself?

If you need parts to do the job head over to Euro Car Parts to find the parts you need.

  • Free UK Delivery
  • 365 Day Returns
  • Free Click and Collect
Fix your L200 problem

Get answers from experts and owners

Add your problem now, it's quick and easy.

Get Answers & Solutions
More 2006 L200 problems
Find your nearest
Diagnostics App

Identify problem parts

Try it now
On Social Media