Car gets hard to start when warm and glow realy doesnt work when warm
2002 Mitsubishi L200 2.5TD with intercooler

hello all.
this starts to happen recently ..car starts fine first morning when cold, glow plugs relay works fine i can hear it clicking, i can see it in dashboard however after i take it for a drive then turn it off for like 5 mins or so, try to restart engine it gets hard to start and take few turns to get it going and also i noticed that glow plug relay doesn't click and nothing on dashboard... any ideas fellas ?

Problem added: Jul 12, 2013 (8 years ago)
Avatar
IoDS
5 points

Mitsubishi L200
Year: 2002
Variant: 2.5TD with intercooler
Problem Category
Electrics, ECU, Warnings & Lights

Replies and fixes

Glow plugs not needed or operating when engine warm , check crank sensor .

This problem is archived

If you're having a similar problem please click below to re-post this problem, you can then customise it to suit your situation.

AutoInsider earns a commission on sales generated by the below links

Thinking about a DIY fix?

If it's a DIY fix and you need parts to do the job head over to Euro Car Parts.

  • Free UK Delivery
  • 365 Day Returns
  • Free Click and Collect

Thinking about changing the car?

£32,550
2020 Mitsubishi L200 2.3L DC Barbarian DI-D

View Car
£25,375
2019 Mitsubishi L200 2.4L DC Barbarian DI-D

View Car
£23,375
2018 Mitsubishi L200 2.4L DC Barbarian DI-D

View Car
AutoInsider AI Robot picture

Helpful & Related Pages on AutoInsider

Generated by AIBot
Parts mentioned on this page
Glow Plugs
Click to read more about the part & problem symptoms
Glow Plug Relay
Click to read more about the part & problem symptoms
L200 Recalls
Click to see a list of the latest Mitsubishi L200 Recalls
Having a problem with your Mitsubishi L200?

Tell us about your L200 problem