2010 Ford S-Max 2.0TDCi
Front & Rear wipers not switching on.

Avatar
eurotraveller
Driver
2 points

Problem added: Nov 18, 2015 (4 years ago)
After heavy rain the front wipers didn't switch on , nor did the rear ones. The rear one does work for one sweep with the wash function, but fronts not at all even with wash function.
Fuse maybe? so where is the fuse box?

Car details
Car: Ford S-Max
Variant: 2.0TDCi
Model Year: 2010
Category: Electrics, ECU, Warnings & Lights
Replies and Fixes
Avatar
eurotraveller
Driver
2 points

Nov 18, 2015 (4 years ago)
I found the car manual online, found which fuse for the wipers, F22-30A in engine compartment fuse box, , went to the car, opened fuse box , removed correct fuse, checked with AVO meter-OK, replaced fuse in box, the wipers now work, front and rear.
Sorted-MAYBE!
Post a reply
Please login to reply.

Options for fixing the problem

Fix the problem yourself

If you need parts to do the job head over to Euro Car Parts to find the parts you need.

  • Free UK Delivery
  • 365 Day Returns
  • Free Click and Collect
Find a Local Mechanic

Use our AutoInsider Find A Specialist search, find garages and mobile mechanics near you.

Simply enter your postcode, select the required specialist areas and view your results.


AutoInsider AI Robot picture

You might find these links to parts and similar problems helpful in solving this problem.
AIBot

Having a problem with your Ford S-Max?

Tell us about your S-Max problem

News & Updates
Win £50 every month by answering problems
Are you a mechanic or handy with car repairs?

Need an MOT after lockdown?
Find your nearest MOT Test Centre

Volvo Seat Belt Recall
Affects S60CC, V60CC, S60, XC60, V60, XC70, V70 and S80

On Social Media