Loss of power

2004 Ford Mondeo Problem

The Problem

Avatar susan4192
Joined: 8 years ago | Fixes: 3 | Profile
About

Hi,
when in idle my car will tick over perfectly.
when driving the car is losing power under load, it will go to about 5000 and then gradually decreases in engine speed until the car is not able to go above 2000 revs.
i had the AA man come and look at it and couldnt do anything with it as the car is not registering any fault codes.
does anyone have any ideas what could be causing this?
all advice greatly appreciated.
Susan


Car Ford Mondeo
Variant 1800
Model Year 2004
Category Running Rough, Starting & Power Loss

All Ford Mondeo Problems

Solution

Avatar whittingehame
Joined: 9 years ago | Fixes: 11,974 | Profile

Possibly fuel filter ?

Solution

Avatar wiggy4170
Joined: 10 years ago | Fixes: 425 | Profile

could be a blocked exhaust or cataltic converter does it sound like it is roaring when you drive it

Solution

Avatar susan4192
Joined: 8 years ago | Fixes: 3 | Profile

Hi again,

my partner fitted a new filter yest, that was the first thing he thought of aswell, the car doesnt sound any different and had a new cat fitted 2 months ago for its mot.

is there any tests that can be done at home to check the exhaust?

could the fuel pump have something to do with it?

Question

Avatar susan4192
Joined: 8 years ago | Fixes: 3 | Profile

my partner drove the car this morning andit drove fine full power for about half a mile then started cutting out again, dont know if it will hep, just trying to give as detailed a description as possible

Solution

Avatar whittingehame
Joined: 9 years ago | Fixes: 11,974 | Profile

Could be a blocked exhaust or catalytic converter as suggested by " wiggy4170 " , may be a faulty part which should be under waranty if only 2 months old .

Solution

Avatar Tez 66
Joined: 9 years ago | Fixes: 93 | Profile

could be a lambda sensor i have known these to fail and not put the engine warning lamp on.

Social Media