2007 Volkswagen Polo 1.9tdi All indicators not working few minutes after towing a trailer

Volkswagen Polo Problem
The Problem
Avatar
Levy
Fixes: 1
Profile
All indicators not working few minutes after towing a trailer
Mar 27, 2020 (1 month ago)
All the indicators were still working fine up until I had to use a trailer,few minutes later after towing the trailer,the left side started flicking faster and later the right side one started flicking faster on a cluster but outside not working

Car details
Car: Volkswagen Polo
Variant: 1.9tdi
Model Year: 2007
Category: Engine & Drivetrain

Recalls: Volkswagen Polo Recalls
More: Volkswagen Polo Problems
Replies and solutions
Avatar
whittingehame
Fixes: 12,347
Profile
Mar 27, 2020 (1 month ago)
If trailer wired up , there used to be a be a new flasher unit needing fitted . This may have changed , years since I fitted a tow bar and not an auto electrician .Otherwise problems with towing socket / wiring
Avatar
Levy
Fixes: 1
Profile
Mar 30, 2020 (1 month ago)
Thanks a lot, I'll try new flasher unit
Avatar
whittingehame
Fixes: 12,347
Profile
Mar 30, 2020 (1 month ago)
It was a heavier duty flasher unit that was needed , whether that is still the case I could not say
Post a reply
Please login to reply
Planning on fixing the problem yourself?

If you need parts to do the job head over to Euro Car Parts to find the parts you need.

  • Free UK Delivery
  • 365 Day Returns
  • Free Click and Collect
Fix your Polo problem

Get answers from experts and owners

Add your problem now, it's quick and easy.

Get Answers & Solutions
Find your nearest
Recent Car Problems
Diagnostics App

Identify problem parts

Try it now
On Social Media