2010 Volkswagen Polo 1.4 Electronic & power steering

Volkswagen Polo Problem
The Problem
Avatar
Kane425
Fixes: 4
Profile
Electronic & power steering
Apr 16, 2017 (2 years ago)
Hi guys
Am having some problems with my 1.4 polo year 2010
My abs light keeps on everytime.. then sometime the light sign also apears
Now since 2 days, all the electricity on the dashboard keeps on and off while am driving.. but the engine itself keep working on...
And when its goes back ON again, i have no power steering. .. have to turn off the engine then back ON again to solve this
Why the dashboard keeps going on and off and the power steering goes off
Are the two problem linked??
Thanks for helping

Car details
Car: Volkswagen Polo
Variant: 1.4
Model Year: 2010
Category: Steering, Suspension, Brakes, Wheels & Tyres

Recalls: Volkswagen Polo Recalls
More: Volkswagen Polo Problems
Parts mentioned in this problem
Replies and solutions
Avatar
whittingehame
Fixes: 12,225
Profile
Apr 17, 2017 (2 years ago)
You need to get it scanned .Your power steering is EPAS and you lose it when dash fails .Could load test alternator and battery .
Avatar
Kane425
Fixes: 4
Profile
Apr 17, 2017 (2 years ago)
Hi.. thanks for your reply
What is EPAS ??
When u say scan... it mean i have to scan the whole car?
Forgot to tell you that i went to an electrician befor... he change the retifier as the batry light was remaining ON. .. its after this zat the problem begins. ..
Avatar
whittingehame
Fixes: 12,225
Profile
Apr 17, 2017 (2 years ago)
Electronic power assisted steering .The rectifier is part of the alternator .Take it back to the electrician that " fixed " it and tell him of the faults since his repair ..
Avatar
Kane425
Fixes: 4
Profile
Aug 11, 2017 (2 years ago)
Hi guys.. i have a volkswagen polo year 2010
1390cc engine with air conditioning system
I just bought a litle apparatuse HH OBD car bluetooth diagnostic kit and i want to use it on my car
I downloaded Torque lite, Eobd facile, obd car doctor free but non of it can conect to the car
I plugged the kit and put the engine ON
Then get to conect on the application. . But it says "is the ignition on?"
"Is the obd kit support by tour car?"
Do you think its the kit which is not compatible or its the application been use??
Post a reply
Please login to reply
Planning on fixing the problem yourself?

If you need parts to do the job head over to Euro Car Parts to find the parts you need.

  • Free UK Delivery
  • 365 Day Returns
  • Free Click and Collect
Fix your Polo problem

Get answers from experts and owners

Add your problem now, it's quick and easy.

Get Answers & Solutions
More 2010 Polo problems
Find your nearest
Diagnostics App

Identify problem parts

Try it now
On Social Media