2009 Skoda Octavia elegance Engine starting issue

Avatar
nedmce

Profile
Problem added: May 23, 2013 (7 years ago)
Skoda will not start. Dash lights flicker when to turn the ignition and engine makes notice like a slot machine. It's like there is no power. However, radio, climate & windscreen wipers work ok. Any ideas what could be wrong?

Car details
Car: Skoda Octavia
Variant: elegance
Model Year: 2009
Category: Running Rough, Starting & Power Loss

Recalls: Skoda Octavia Recalls
More: Skoda Octavia Problems
Parts mentioned in this problem
Replies and solutions
Avatar
roverman
Fixes: 392
Profile
May 23, 2013 (7 years ago)
first thing to do is check battery connections are secuure try starting with jump leads if ok haqve battery tested / replaced then check charge rate
Avatar
hitman501
Fixes: 1
Profile
Jun 3, 2013 (7 years ago)
Have have a similar problem when warm my car turns over to 500 revs then cuts out when start again does the same but then finds its tick over changed injectors throttle peddle throttle body turbo sensor water temp sensor but no change and no fault codes show help
Post a reply
Please login to reply
Planning on fixing the problem yourself?

If you need parts to do the job head over to Euro Car Parts to find the parts you need.

  • Free UK Delivery
  • 365 Day Returns
  • Free Click and Collect
Fix your Octavia problem

Get answers from experts and owners

Add your problem now, it's quick and easy.

Get Answers & Solutions
More 2009 Octavia problems
Find your nearest
Recent Car Problems
Hyundai Tucson
Third gear
Renault Megane
Noise
Vauxhall Corsa
Boot not opening
Mercedes Benz C Class
Over heating
Hyundai Coupe
Battery drainning
Vauxhall Antara
Gears
Citroen C4
Electrics
Diagnostics App

Identify problem parts

Try it now
On Social Media