1994 827 sterling going about 50mph the speedo will drop to zero for a few seconds then go back to reading normal no gear change occurs but s4 light flashes on dashboard
1994 Rover 800 2.7 sterling

i can be driving down the road about 50mph and the speedo needle drops to zero for a few seconds then returns to normal but a green s4 light flashes on the dashboard but it seems to drive ok with no gear change when i stop and turn off the ignition then back on there is no light flashing and it drives normaly

Problem added: May 10, 2022 (2 weeks ago)

Rover 800
Year: 1994
Variant: 2.7 sterling
Problem Category
Electrics, ECU, Warnings & Lights

Replies and fixes

A few possible causes . You could test your battery voltage and also alternator charging rate . Check wheel speed sensor / wiring . Instrument cluster fault is another possibility .

Post a reply

AutoInsider earns a commission on sales generated by the below links

Thinking about a DIY fix?

If it's a DIY fix and you need parts to do the job head over to Euro Car Parts.

  • Free UK Delivery
  • 365 Day Returns
  • Free Click and Collect

Thinking about changing the car?

If you're thinking of changing your Rover 800 get a valuation from Cazoo.

  • Haggle-free experience
  • Guaranteed for 7 days
  • Fast payment
AutoInsider AI Robot picture

Helpful & Related Pages on AutoInsider

Generated by AIBot
Parts mentioned on this page
Alternator
Click to read more about the part & problem symptoms
Battery
Click to read more about the part & problem symptoms
More Problems
See more Rover 800 Problems
Having a problem with your Rover 800?

Tell us about your 800 problem