1999 Rover 400 injection
Non starter

Avatar
shanehiggins
Driver
1 points

Problem added: Nov 26, 2008 (11 years ago)
my wifes rover 400 has stopped running. the car was running fine then all of a sudden just stopped going, it wont start, it turns over, ive changed the rotor arm and the dibby cap but still nothing. the rotor arm spins and theres power going to the leads but still not firing up. could it be lack of fuel to the injection system, my neighbour is a mechanic and tried some quick start in the air filter system but im still stuck, any help or hints without having to strip out the injectors would be great, regards shane

Car details
Car: Rover 400
Variant: injection
Model Year: 1999
Category: Running Rough, Starting & Power Loss
Replies and Fixes
Avatar
phil5555
Driver
86 points

Dec 2, 2008 (11 years ago)
Is the cam belt in one piece?
Post a reply
Please login to reply.
Planning on fixing a problem yourself?

If you need parts to do the job head over to Euro Car Parts to find the parts you need.

  • Free UK Delivery
  • 365 Day Returns
  • Free Click and Collect
Having a problem with your Rover 400?

Tell us about your 400 problem

AutoInsider AI Robot picture

You might find these links helpful in solving this problem.
AIBot

Helpful Links
More Problems
See more Rover 400 Problems
More 1999 400 problems
News & Updates
Need an MOT after lockdown?
Find your nearest MOT Test Centre

Volvo Seat Belt Recall
Affects S60CC, V60CC, S60, XC60, V60, XC70, V70 and S80

AutoInsider recall database updated
Recent recalls for Volvo, Audi and Porsche

Find your nearest
Diagnostics App

Identify problem parts

Try it now
On Social Media