Flickering lights etc
1996 Rover 400 1.6 SI

Avatar
Deborah
Driver
1 points

Problem added: Dec 15, 2007 (13 years ago)
I went over a bump and the ABS light came on and the radio went off briefly before restarting again and the ABS light going out.

Things are now getting worse the above happens and the speedo and rev counter drops, the lights flicker, the clock resets back to 0.00 and then everything comes back on again.

Any ideas please?

Car details
Car: Rover 400
Variant: 1.6 SI
Model Year: 1996
Category: Running Rough, Starting & Power Loss
Replies and Fixes
Avatar
mr suzuki
Top Fixer
694 points

Dec 16, 2007 (13 years ago)
hi the abs is fused straight from the main fusebox,so id start looking at the battery connections,the earth lead and the main fuses(usually bolted into fuse box)also the main relay.if all connections ok try the contacts on the back of the iggy lock.otherwise check wireing loomb for damage poss near aux wireing has anyone wired in aftermarket radio or spots

This problem is archived

If you're having a similar problem please click below to re-post this problem, you can then customise it to suit your situation.


Options for fixing the problem

Fix the problem yourself

If you need parts to do the job head over to Euro Car Parts to find the parts you need.

  • Free UK Delivery
  • 365 Day Returns
  • Free Click and Collect
Find a Local Mechanic

Use our AutoInsider Find A Specialist search, find garages and mobile mechanics near you.

Simply enter your postcode, select the required specialist areas and view your results.


AutoInsider AI Robot picture

You might find these links to parts and similar problems helpful in solving this problem.
AIBot

Having a problem with your Rover 400?

Tell us about your 400 problem

On Social Media