Electrical fault
2001 Peugeot 406 2.0 hdi

Avatar
brian pennock
Driver
1 points

Problem added: Jan 31, 2011 (10 years ago)
Heater display, information display,dashboard all lite and engine running after the ignition key turned off and removed. Have to apply foot brake to stop engine and turn the displays off. Displays relight when you release the foot brake pedal. I've isolated the ignition swicth and rear lights but faults persist. Any help or ideas would be great!!
Car: Peugeot 406
Variant: 2.0 hdi
Model Year: 2001
Category: Running Rough, Starting & Power Loss
Replies and Fixes
Avatar
Pauls-diagnostics
Driver
33 points

Jan 31, 2011 (10 years ago)
Sounds like it could be an engine contole module fault.Best bet with this sort of fault is try get it scanned to see what faults codes come.Problem with peugeot is there french same as renault and renound for electrical issues..
Avatar
paulieone
Legend
1,786 points

Feb 1, 2011 (10 years ago)
could be a couple of things i.e under bonnet fuse box or maybe bsi fault.

This problem is archived

If you're having a similar problem please click below to re-post this problem, you can then customise it to suit your situation.

What to do next?

Fix the problem yourself...

If you need parts to do the job head over to Euro Car Parts to find the parts you need.

  • Free UK Delivery
  • 365 Day Returns
  • Free Click and Collect
or Find a Local Mechanic

Use our AutoInsider Find A Specialist search, find garages and mobile mechanics near you.

Simply enter your postcode, select the required specialist areas and view your results.

Helpful & Related Pages on AutoInsider
Generated by AutoInsider AIBot
AutoInsider AI Robot picture
Having a problem with your Peugeot 406?

Tell us about your 406 problem

On Social Media