Engine not running properly
2010 Peugeot 207 1.6 110 sport hdi

Only runs with the mass air flow meter disconnected . Had a new one fitted still the same so took off .. erg valve done .. very confused any help would be great thanks

Problem added: Nov 12, 2021 (3 weeks ago)
Avatar
Darren
1 points
Peugeot 207 (2010)
1.6 110 sport hdi
Problem Category
Engine & Drivetrain
Replies and fixes
You scanned it for fault codes ?
Yes had it to garage he’s left scratching his head … runs fine when the mass air flow is unplugged … runs ruff and really Smokey when re connected
Was it a OEM MAF ? or one of the dodgy cheap ones that are often duff and give you a bum steer thinking you can eliminate it because replaced ?
Not sure what one the garage used .. just strange that it runs great without the air flow meter unplugged.. just seems to have no boost from turbo .. suppose not enough air going in
Post a reply
Thinking about a DIY fix?

If it's a DIY fix and you need parts to do the job head over to Euro Car Parts.

  • Free UK Delivery
  • 365 Day Returns
  • Free Click and Collect
Helpful & Related Pages on AutoInsider
Generated by AutoInsider AIBot
AutoInsider AI Robot picture
Parts mentioned on this page
Mass Air Flow Sensor (MAF)
Click to read more about the part & problem symptoms

Recalls
Click to see a list of Peugeot 207 Recalls
More Problems
See more Peugeot 207 Problems
Verve 1.4 petrol Exhaust high pressure
1.6VTI Sport Engine failure after low oil pressure warning
Having a problem with your Peugeot 207?

Tell us about your 207 problem

On Social Media