Solenoid issues in gear box?
2007 Peugeot 207 1.6 Sport Auto (120)

Hi peeps,

My 207 auto (2007) has been playing up every time I try and accelerate with a cold engine. The gearbox makes a "thump / thud" sound, then sticks itself into "safe mode" (it flashes both the sport S and the winter snowflake symbols on the dash) until I can pull over and shut the engine down for about 45 - 60 seconds, then re-starts ok. I've been told by my dealer that the solenoid(s) may be at fault. Any idea what could have caused it?

The car hasn't been abused at all (I'm an IAM member, so try to be a little more careful with my car) and it only seems to have started playing up since I had a temperature sensor replaced last year...

Problem added: Sep 28, 2012 (9 years ago)
Avatar
Kaz74
13 points
Peugeot 207 (2007)
1.6 Sport Auto (120)
Problem Category
Running Rough, Starting & Power Loss
Replies and Fixes
Could be a faulty or sticking solenoid. Best bet would be to take the car to an automatic gearbox specialist. They may have a better idea, or may have come across this problem before... Hope this helps...
Replacing the modulating solenoid valves (2) and transmission fluid along with a software update for gearbox and engine ecu along with autoadaptive reset should cure your issue.
Thanks peeps - I've now had the solenoids replaced, and the software updated, and the car is seriously smooth.

This problem is archived

If you're having a similar problem please click below to re-post this problem, you can then customise it to suit your situation.

Thinking about a DIY fix?

If it's a DIY fix and you need parts to do the job head over to Euro Car Parts.

  • Free UK Delivery
  • 365 Day Returns
  • Free Click and Collect
Helpful & Related Pages on AutoInsider
Generated by AutoInsider AIBot
AutoInsider AI Robot picture
Having a problem with your Peugeot 207?

Tell us about your 207 problem

On Social Media