1996 Nissan Terrano - speedo not working. have replaced original gear box with 2nd hand box. auto g/box.

Terrano R3-mR Problem
The Problem
Avatar
Terrano man

Profile
speedo not working. have replaced original gear box with 2nd hand box. auto g/box.
Jan 19, 2013 (7 years ago)
speedo not working since i have changed gear box over, not sure what to check to find problem.G/box has two sensors which appear to be connected and not damaged.the original box had a switch to four wheel drive with a 2 and 4 wheel shift. the new box is manual push into 2 or 4 wheel drive on stick shift.also the original box had 8 connections to power!! new box has 6!! can anyone help with my problem.

Car: Nissan Terrano
Variant: R3-mR
Year: 1996
Category: Electrics, ECU, Warnings & Lights
Recalls: Nissan Terrano Recalls
More: Nissan Terrano Problems
Ad
Avatar
bustedknuckles
Fixes: 1,458
Profile
Jan 20, 2013 (7 years ago)
Is possible your connector to the speed sensor is not wired if your connections are different guess you need to find the speed sensor and physically trace the wiring to check it,s ok.
Avatar
KennyG
Fixes: 1
Profile
Feb 20, 2017 (2 years ago)
Have you had a look at this similar problem: speedo not working. have replaced original gear box with 2nd hand box. auto g/box.

This message was auto-generated based on a user suggestion.
Post a reply
Please login to reply

Can't find a solution to your problem?
Planning on fixing the problem yourself?

If you need parts to do the job head over to Euro Car Parts to find the parts you need.

  • Free UK Delivery
  • 365 Day Returns
  • Free Click and Collect