2006 Nissan Liberty 1998
Not pulling as if high pressure pump is not working

Avatar
reason
Driver
1 points

Problem added: Dec 4, 2020 (1 month ago)
Nissan liberty not pulling or ravv normal producing pop sound acting as if its misfiring but gets stady and pulls when return valve pipe is blocked.It actually sound as if exhaust pipe is blocked by something i even thought its the high pressur pump with the problem so i installed new one but problem is still unsolved

Car details
Car: Nissan Liberty
Variant: 1998
Model Year: 2006
Category: Running Rough, Starting & Power Loss
Replies and Fixes
Avatar
whittingehame
Legend
16,706 points

Dec 4, 2020 (1 month ago)
Could be exhaust or cat partially blocked . You could also try scanning for any fault codes . Not sure if that vehicle has an in line or in tank fuel filter
Post a reply
Please login to reply.

Options for fixing the problem

Fix the problem yourself

If you need parts to do the job head over to Euro Car Parts to find the parts you need.

  • Free UK Delivery
  • 365 Day Returns
  • Free Click and Collect
Find a Local Mechanic

Use our AutoInsider Find A Specialist search, find garages and mobile mechanics near you.

Simply enter your postcode, select the required specialist areas and view your results.


AutoInsider AI Robot picture

You might find these links to parts and similar problems helpful in solving this problem.
AIBot

Helpful & Related Links
Parts mentioned on this page

More Problems
See more Nissan Liberty Problems
Having a problem with your Nissan Liberty?

Tell us about your Liberty problem

News & Updates
Win £50 every month by answering problems
Are you a mechanic or handy with car repairs?

Need an MOT after lockdown?
Find your nearest MOT Test Centre

Volvo Seat Belt Recall
Affects S60CC, V60CC, S60, XC60, V60, XC70, V70 and S80

On Social Media