2000 Nissan Elgrand 3.5 V6 PETROL
ENGINE FAULT DIAGNOSED MAF SENSOR FAULT CHANGED SENSOR STILL SHOWING FAULT

Avatar
PAUL BENSON
Driver
1 points

Problem added: Aug 13, 2020 (1 month ago)
ORIGINAL PARTS FITTED STILL NO JOY! ALTHOUGH THE MACHINE DETECTED MAF SENSOR COULD THE FAULT LYE ELSEWHERE???

Car details
Car: Nissan Elgrand
Variant: 3.5 V6 PETROL
Model Year: 2000
Category: Electrics, ECU, Warnings & Lights
Replies and Fixes
Avatar
bustedknuckles
Legend
1,846 points

Aug 17, 2020 (1 month ago)
Would be checking for any air leaks in the induction system and that nothings obstructing the intake first of all
Avatar
PAUL BENSON
Driver
1 points

Aug 17, 2020 (1 month ago)
The engine has only done 33k since new although she is 20 years old but immaculate all the same. it was fitted with the new OEM MAF sensor and initially after fitting all was reset lights out, then after 10 miles it comes on.
but will check all hoses just incase.
Thanks
Post a reply
Please login to reply.
Planning on fixing a problem yourself?

If you need parts to do the job head over to Euro Car Parts to find the parts you need.

  • Free UK Delivery
  • 365 Day Returns
  • Free Click and Collect
Having a problem with your Nissan Elgrand?

Tell us about your Elgrand problem

AutoInsider AI Robot picture

You might find these links helpful in solving this problem.
AIBot

Helpful Links
More Problems
See more Nissan Elgrand Problems
Parts mentioned on this page
More 2000 Elgrand problems
News & Updates
Need an MOT after lockdown?
Find your nearest MOT Test Centre

Volvo Seat Belt Recall
Affects S60CC, V60CC, S60, XC60, V60, XC70, V70 and S80

AutoInsider recall database updated
Recent recalls for Volvo, Audi and Porsche

Find your nearest
Diagnostics App

Identify problem parts

Try it now
On Social Media