Intermittent loss of power
2009 Mitsubishi Shogun 3.2did auto diesel

Avatar
Bernard ANGUS Angus
Driver
1 points

Problem added: Dec 5, 2019 (1 year ago)
Has only 75k and am second owner.
Recently fully serviced. New exhaust. New fuel tank. all filters
Intermittently it loses power when pulling away or slowing down. Will eventually clear and run maybe for 20-30 miles before it happens again. Manifolds cleaned EGR cleaned. No codes showing on diagnostics. DRIVING ME MAD !!!

Car details
Car: Mitsubishi Shogun
Variant: 3.2did auto diesel
Model Year: 2009
Category: Running Rough, Starting & Power Loss
Replies and Fixes
Avatar
whittingehame
Legend
18,655 points

Dec 5, 2019 (1 year ago)
Could check the air flow meter sensor , failing diesel pump or injectors needing serviced ?

This problem is archived

If you're having a similar problem please click below to re-post this problem, you can then customise it to suit your situation.


Options for fixing the problem

Fix the problem yourself

If you need parts to do the job head over to Euro Car Parts to find the parts you need.

  • Free UK Delivery
  • 365 Day Returns
  • Free Click and Collect
Find a Local Mechanic

Use our AutoInsider Find A Specialist search, find garages and mobile mechanics near you.

Simply enter your postcode, select the required specialist areas and view your results.


AutoInsider AI Robot picture

You might find these links to parts and similar problems helpful in solving this problem.
AIBot

Helpful & Related Links
Recalls
Click to see a list of Mitsubishi Shogun Recalls
Parts mentioned on this page

More Problems
See more Mitsubishi Shogun Problems

Diamond No power
3.2 diamond auto Intermittent starting
Having a problem with your Mitsubishi Shogun?

Tell us about your Shogun problem

On Social Media