Mc2 not running or starting
2008 Microcar MC2 Mc2

Avatar
Stephen yapp
Driver
1 points

Problem added: Jul 23, 2021 (1 month ago)
I have mc2 problem verry hard to start will tick over but as soon as you go to push the pedel it couths then stops some times not starting at all ive checked fule pump working relays new all wireing been check need help

Pluges checked working and sparks
Car: Microcar MC2
Variant: Mc2
Model Year: 2008
Category: Running Rough, Starting & Power Loss
Replies and Fixes
Avatar
whittingehame
Legend
21,029 points

Jul 23, 2021 (1 month ago)
Try changing the engine coolant temp sensor , tells the ECU how much fuel is needed for engine .
Avatar
Stephen yapp
Driver
1 points

Jul 26, 2021 (1 month ago)
Done that m8 dident change anything still not starting

Steve
Avatar
whittingehame
Legend
21,029 points

Jul 26, 2021 (1 month ago)
Check if a fuel filter fitted and replace if so , check fuel pressure . Check or replace crankshaft sensor and check wiring / connection / plug .
Avatar
Stephen yapp
Driver
1 points

Jul 26, 2021 (1 month ago)
Ok what sort of fuel pressure should it be

Fuel filter fitted is verry large. 3.5” x 6” is this right looks wronge to me


Steve
Post a reply
Please login to reply.

What to do next?

Fix the problem yourself...

If you need parts to do the job head over to Euro Car Parts to find the parts you need.

  • Free UK Delivery
  • 365 Day Returns
  • Free Click and Collect
or Find a Local Mechanic

Use our AutoInsider Find A Specialist search, find garages and mobile mechanics near you.

Simply enter your postcode, select the required specialist areas and view your results.

Helpful & Related Pages on AutoInsider
Generated by AutoInsider AIBot
AutoInsider AI Robot picture
More Problems
See more Microcar MC2 Problems
Having a problem with your Microcar MC2?

Tell us about your MC2 problem

On Social Media