Dashboard lights going haywire whilst being driven
2010 Mazda 2 1.3 TS

Being driven at normal road speeds (30mph) dash lights go crazy, speedo shows speeds in excess of 80mph. Happens for several seconds before all return to normal

Problem added: Sep 27, 2021 (3 weeks ago)
Mazda 2 (2010)
1.3 TS
Problem Category
Electrics, ECU, Warnings & Lights
Replies and Fixes
One thing you could get checked would be LOAD testing your battery and alternator , could be a surge causing it . Simple 5 min check that the likes of Halfords usually do free of charge while you wait . But they do suffer from instrument cluster faults also ,

https://www.autotronics.co.uk/product/mazda-2-instrument-cluster-repair

https://electrotech-uk.co.uk/instrument-cluster-repairs/mazda-instrument-cluster-repairs/mazda-2-instrument-cluster-repairs/

http://www.clusterrepairsuk.co.uk/repair/model/mazda-2-instrument-cluster-speedo-mk2
Post a reply
Thinking about a DIY fix?

If it's a DIY fix and you need parts to do the job head over to Euro Car Parts.

  • Free UK Delivery
  • 365 Day Returns
  • Free Click and Collect
Helpful & Related Pages on AutoInsider
Generated by AutoInsider AIBot
AutoInsider AI Robot picture
Parts mentioned on this page
Alternator
Click to read more about the part & problem symptoms
Battery
Click to read more about the part & problem symptoms

Recalls
Click to see a list of Mazda 2 Recalls
More Problems
See more Mazda 2 Problems
Having a problem with your Mazda 2?

Tell us about your 2 problem

On Social Media