Clicking noise from front,
2003 Land Rover Freelander

After some heavy rain, I had problem with the electrics, particularly the central locking and alarm. When driving for an hour or so noticed speedo and fuel gauge not working. They then started again but a clicking noise had started when the car stopped at lights etc. when the car was running normally no noise only when stopped. When I turned off the motor and just put the ignition back on the ticking persisted. Since then have had intermittent problems with the alarm. The noise sounds like two gears not meshing but just hitting each other's teeth, car runs normally, no starting problems and all lights etc are working. There is no obvious damp in fuses etc. ticking only occurs after running for about an hour. Before then it's normal.

Problem added: Aug 28, 2014 (7 years ago)
Avatar
Oberon
1 points
Land Rover Freelander (2003)
Problem Category
Running Rough, Starting & Power Loss
Replies and fixes
Sounds like a relay clicking from what you say . Case of trying to locate which one by tracing noise .

This problem is archived

If you're having a similar problem please click below to re-post this problem, you can then customise it to suit your situation.

Thinking about a DIY fix?

If it's a DIY fix and you need parts to do the job head over to Euro Car Parts.

  • Free UK Delivery
  • 365 Day Returns
  • Free Click and Collect
Helpful & Related Pages on AutoInsider
Generated by AutoInsider AIBot
AutoInsider AI Robot picture
Having a problem with your Land Rover Freelander?

Tell us about your Freelander problem

On Social Media