1993 Honda Accord prelude 2.2i vtec Running rough

Honda Accord Problem
The Problem
Avatar
hilzy

Profile
Running rough
Feb 9, 2008 (12 years ago)
car starts perfect first time every time but when ya drive above 3000rpm cold or warm it becomes spluutery and runs really routh if revved above 4000rpm tachometer go's nuts jumping to 7000rpm with no engine change(revs)car generally sounds rough when driving with window down recently topped up oil with 5w-30. annoying as two months ago car was still running like new HELP PLZ!!!!!

Car details
Car: Honda Accord
Variant: prelude 2.2i vtec
Model Year: 1993
Category: Running Rough, Starting & Power Loss

Recalls: Honda Accord Recalls
More: Honda Accord Problems
Replies and solutions
Avatar
mrfixit
Fixes: 316
Profile
Feb 9, 2008 (12 years ago)
Hi there,
It sounds to me like you are having an engine speed sensor related fault, most probably crank position sensor rather than cam sensor, if it is the engine i think you will have in that vehicle they are both part of the distributor and you cannot buy components for them, it will be an exchange unit or send away for repair. If you would like to contact me further to give me any other details on your vehicle or advice you can call me on 07743 215898
Post a reply
Please login to reply
Planning on fixing the problem yourself?

If you need parts to do the job head over to Euro Car Parts to find the parts you need.

  • Free UK Delivery
  • 365 Day Returns
  • Free Click and Collect
Fix your Accord problem

Get answers from experts and owners

Add your problem now, it's quick and easy.

Get Answers & Solutions
Find your nearest
Recent Car Problems
Honda CR-V
C v boot
Vauxhall Astra
Service Vehicle Soon
Mercedes Benz C Class
Plugin flap not opening
Vauxhall Meriva
Warning light
Vauxhall Corsa
Power to Tailgate
Vauxhall Zafira
SPANNER IN THE WORKS
Diagnostics App

Identify problem parts

Try it now
On Social Media