Ecu problem
2012 Ford Mondeo 20 titanium x auto

Avatar
David Wilson
Driver
1 points

Problem added: Aug 14, 2021 (1 month ago)
I've got a 2012 Mondeo titanium x auto, the other day when driven i went to put it reverse and nothing happened just revving same when i put it in drive,
i called someone out and he said it was the( transmission control module) lost communication, he fixed it by wiping the fault but now I'm a bit worried it could come back agene when I'm on the motorway,
any idea's what's the best way to stop in happing agene??
Car: Ford Mondeo
Variant: 20 titanium x auto
Model Year: 2012
Category: Electrics, ECU, Warnings & Lights
Gearbox & Clutch
Engine & Drivetrain
Replies and Fixes
Avatar
whittingehame
Legend
21,026 points

Aug 14, 2021 (1 month ago)
All I can suggest is to get the TCM cleared / reset if you start to have any problems or symptoms .
Post a reply
Please login to reply.

What to do next?

Fix the problem yourself...

If you need parts to do the job head over to Euro Car Parts to find the parts you need.

  • Free UK Delivery
  • 365 Day Returns
  • Free Click and Collect
or Find a Local Mechanic

Use our AutoInsider Find A Specialist search, find garages and mobile mechanics near you.

Simply enter your postcode, select the required specialist areas and view your results.

Helpful & Related Pages on AutoInsider
Generated by AutoInsider AIBot
AutoInsider AI Robot picture
Recalls
Click to see a list of Ford Mondeo Recalls
More Problems
See more Ford Mondeo Problems
Having a problem with your Ford Mondeo?

Tell us about your Mondeo problem

On Social Media