Cruise control won't engage in 5th gear
2007 Ford Mondeo 1.6 Petrol Hatchback 07-14

Avatar
Dee
Driver
1 points

Problem added: May 11, 2021 (1 month ago)
Works fine in 3rd and 4th gear, go to 5th gear and it will go into "cruise standby" but the set / plus / minus buttons have no effect so the "cruise standby" times out. Works fine at 80 km/hr in 4th so isn't speed related.
If does give an error code complaining about both switches but these have been swapped out and it still gives the same error and behaves the same way.
Any suggestions please?

Car details
Car: Ford Mondeo
Variant: 1.6 Petrol Hatchback 07-14
Model Year: 2007
Category: Electrics, ECU, Warnings & Lights
Gearbox & Clutch
Engine & Drivetrain
Replies and Fixes
Avatar
whittingehame
Legend
19,216 points

May 11, 2021 (1 month ago)
As far as I can remember when that happens it's a problem with a sensor , but cant recollect what one .Probably need scanning to find out .
Avatar
Dee
Driver
1 points

May 11, 2021 (1 month ago)
Replying to post by whittingehame:
As far as I can remember when that happens it's a problem with a sensor , but cant recollect what one .Probably need scanning to find out .
Thanks for your reply, did some more googling based on your suggestion would the Vehicle Speed Sensor ring any bells by any chance?
Avatar
whittingehame
Legend
19,216 points

May 11, 2021 (1 month ago)
VSS failing CAN affect cruise control amongst other circuits
Avatar
Dee
Driver
1 points

May 12, 2021 (1 month ago)
Came across a post of the same thing happening on a Fiesta, not sure if that helps. One of the suggestions on it is the ABS sensor may be at fault?
Seems a bit of a needle in a haystack :(
https://www.fordownersclub.com/forums/topic/116496-cruise-control-not-working-in-5th-gear/
Avatar
Dee
Driver
1 points

May 12, 2021 (1 month ago)
Replying to post by Dee:
Came across a post of the same thing happening on a Fiesta, not sure if that helps. One of the suggestions on it is the ABS sensor may be at fault?
Seems a bit of a needle in a haystack :(
https://www.fordownersclub.com/forums/topic/116496-cruise-control-not-working-in-5th-gear/
Only other sensor I found a reference to in the context of cruise control was Trottle position sensor (TBS) apparently there may be more than one of these which would cause intermittent errors, not sure if that is the case on a Mondeo
Avatar
Dee
Driver
1 points

May 12, 2021 (1 month ago) Edited on May 12, 2021 (1 month ago)
Replying to post by whittingehame:
VSS failing CAN affect cruise control amongst other circuits
Does that the same is occurring in a Fiesta help by any chance? There is a link in the comments above.
Post a reply
Please login to reply.

Options for fixing the problem

Fix the problem yourself

If you need parts to do the job head over to Euro Car Parts to find the parts you need.

  • Free UK Delivery
  • 365 Day Returns
  • Free Click and Collect
Find a Local Mechanic

Use our AutoInsider Find A Specialist search, find garages and mobile mechanics near you.

Simply enter your postcode, select the required specialist areas and view your results.


Having a problem with your Ford Mondeo?

Tell us about your Mondeo problem