2003 Ford Fusion 1.4tdci
No acceleration engine light on

Avatar
charles balloch
Driver
9 points

Problem added: Jan 5, 2018 (2 years ago)
recently had new fanbelt fitted garage reset timing belt as debris had fouled crank pulley now no power garage said egr fault and fitted blanking plate and cleared fault code now they say its massairflow sensor fault/light back on car now very slow to pick up any speed on even the slightest hillit slows right down to a crawl even slower than limphome mode dont want to go back to garage as i dont thinkthey got aclue and just keep taking money of me if someone can give me some advice could probably fix myself as i learnt about cars in the early 60s

Car details
Car: Ford Fusion
Variant: 1.4tdci
Model Year: 2003
Category: Running Rough, Starting & Power Loss
Replies and Fixes
Avatar
whittingehame
Legend
15,454 points

Jan 5, 2018 (2 years ago)
Get another garage .From what you say they probably have set the timing wrongly .Also get it scanned and see what fault codes are stored .
Avatar
1/4drive
Legend
1,890 points

Jan 6, 2018 (2 years ago)
Agreed,
And your likely to get a MAF fault with a blanked off EGR as the computer is "Expecting" to see a MAF change when the EGR is active,
So it doesn't register a MAF reading change it would throw up a MAF code.
Avatar
charles balloch
Driver
9 points

Jan 6, 2018 (2 years ago)
1/4drive thanx for ideas will remove blank plate clean out egr andreplace i bought a new maff sensor so will replace then get fault codes checked
Avatar
roverman
Top Fixer
457 points

Jan 8, 2018 (2 years ago)
Yes sounds like timing is out I would have a competent mechanic check this for you using correct locking tools adjust timing then carry out a compression test to check if any damage has been done to any valves before going any further and wasting your money on guess work do not blank EGR valve clean check or replace valve
Avatar
charles balloch
Driver
9 points

Jun 11, 2019 (1 year ago)
anybody know does a renault master van 2.8dti 1998 have a low pressure fuelpump in the tank my mechanic said van to early for pump and fuel is drawn up by injector pump i recently filled up tank started van got about20 yds engine died no restart checked fuel line tank to filter no fuel had tosuck fuel up to filter as primer bubblewould,nt lift it just need toknow if pump is fitted/faulty
Post a reply
Please login to reply.

Options for fixing the problem

Fix the problem yourself

If you need parts to do the job head over to Euro Car Parts to find the parts you need.

  • Free UK Delivery
  • 365 Day Returns
  • Free Click and Collect
Find a Local Mechanic

Use our AutoInsider Find A Specialist search, find garages and mobile mechanics near you.

Simply enter your postcode, select the required specialist areas and view your results.


AutoInsider AI Robot picture

You might find these links to parts and similar problems helpful in solving this problem.
AIBot

Having a problem with your Ford Fusion?

Tell us about your Fusion problem

News & Updates
Win £50 every month by answering problems
Are you a mechanic or handy with car repairs?

Need an MOT after lockdown?
Find your nearest MOT Test Centre

Volvo Seat Belt Recall
Affects S60CC, V60CC, S60, XC60, V60, XC70, V70 and S80

On Social Media