2003 Ford Focus
Blowheater problem

Avatar
deemc
Driver
1 points

Problem added: Feb 5, 2013 (7 years ago)
got a replacement blow heater and resistor put them in the car but there is still no power getting to the blow heater there is nothing at all, checked the fuses and there is no problem with them, can anyone help

Car details
Car: Ford Focus
Model Year: 2003
Category: Running Rough, Starting & Power Loss
Replies and Fixes
Avatar
whittingehame
Legend
16,846 points

Feb 5, 2013 (7 years ago)
On some models f64 in the engine compartment fuse box covered that circuit , checked it out ?
Avatar
bustedknuckles
Legend
2,301 points

Feb 5, 2013 (7 years ago)
Can you do a continuity check on the wiring between fuse box feed and motor to establish that it,s not a broken or melted wire.
Post a reply
Please login to reply.

Options for fixing the problem

Fix the problem yourself

If you need parts to do the job head over to Euro Car Parts to find the parts you need.

  • Free UK Delivery
  • 365 Day Returns
  • Free Click and Collect
Find a Local Mechanic

Use our AutoInsider Find A Specialist search, find garages and mobile mechanics near you.

Simply enter your postcode, select the required specialist areas and view your results.


Having a problem with your Ford Focus?

Tell us about your Focus problem

News & Updates
Win £50 every month by answering problems
Are you a mechanic or handy with car repairs?

Need an MOT after lockdown?
Find your nearest MOT Test Centre

Volvo Seat Belt Recall
Affects S60CC, V60CC, S60, XC60, V60, XC70, V70 and S80

On Social Media