1999 Ford Focus 1.8 Zetec Estate Blowers not working!

Avatar
NewbieSam
Fixes: 2
Profile
Problem added: Oct 22, 2008 (11 years ago)
Hi, I was wondering if anyone out there can help me. I have a 1999 Focus Estate and the blowers have stopped working completely - just in time for Winter!! I checked the handbook, located the fuse in the box in the engine, saw that it was blown and replaced it. Twice! The fuses just blew again straight away, indicating another problem. I don't know a lot about cars, although I'm not afraid of having a go, and I'm a bit skint at the mo', so if anyone could advise me of my next step, I'd be very grateful! Cheers for that, Sam

Car details
Car: Ford Focus
Variant: 1.8 Zetec Estate
Model Year: 1999

Recalls: Ford Focus Recalls
More: Ford Focus Problems
Replies and solutions
Avatar
phil5555
Fixes: 73
Profile
Oct 24, 2008 (11 years ago)
Possibly the heater fan switch, some fan motors have a resistance pack - it could be that also.
Avatar
mastertech
Fixes: 220
Profile
Oct 28, 2008 (11 years ago)
suspect resistor has their been any burning smells? if so new resistor
Post a reply
Please login to reply
Planning on fixing the problem yourself?

If you need parts to do the job head over to Euro Car Parts to find the parts you need.

  • Free UK Delivery
  • 365 Day Returns
  • Free Click and Collect
Fix your Focus problem

Get answers from experts and owners

Add your problem now, it's quick and easy.

Get Answers & Solutions
Find your nearest
Recent Car Problems
Diagnostics App

Identify problem parts

Try it now
On Social Media