Indicators and hazzards not working
2005 Ford Fiesta 1.4 style tdci

Avatar
wiganhammer
Driver
2 points

Problem added: Jan 13, 2011 (10 years ago)
indicators or hazzards not working but still makes clicking noise

Car details
Car: Ford Fiesta
Variant: 1.4 style tdci
Model Year: 2005
Category: Electrics, ECU, Warnings & Lights
Replies and Fixes
Avatar
2145simon
Legend
1,055 points

Jan 13, 2011 (10 years ago)
i take it the clicking noise is coming from instrument panel,you need to locate the fusebox and check the flasher unit and make sure the relay is working properly and the wiring is ok and that indicator fuse is ok
Avatar
whittingehame
Legend
18,303 points

Jan 13, 2011 (10 years ago)
Try pushing hazard warning light switch on/ off a few times as sometimes it sticks causing this fault .

This problem is archived

If you're having a similar problem please click below to re-post this problem, you can then customise it to suit your situation.


Options for fixing the problem

Fix the problem yourself

If you need parts to do the job head over to Euro Car Parts to find the parts you need.

  • Free UK Delivery
  • 365 Day Returns
  • Free Click and Collect
Find a Local Mechanic

Use our AutoInsider Find A Specialist search, find garages and mobile mechanics near you.

Simply enter your postcode, select the required specialist areas and view your results.


AutoInsider AI Robot picture

You might find these links to parts and similar problems helpful in solving this problem.
AIBot

Having a problem with your Ford Fiesta?

Tell us about your Fiesta problem