Ford Fiesta Clutch Pedal
2006 Ford Fiesta 1.25 zetec climate

Avatar
niki
Driver
4 points

Problem added: Nov 8, 2009 (11 years ago)


I have an 06 ford fiesta zetec climate. in july just before its 3 year warranty was up i experienced a problem where i thought the clutch had gone as the clutch had no power to it at all. On calling the RAC out out they told me it was a common problem & would put a clamp on the pedal to stop it happening again.
Here we are 4 months later the self same thing has happened again..coincidently in the same place as well!!! The RAC have replaced the clamp today but told me this needs looking at by ford,as this occured first time within the warranty i have emailed them today & asked for them to view this matter. Has anybody else expereinced this problem
Car: Ford Fiesta
Variant: 1.25 zetec climate
Model Year: 2006
Category: Running Rough, Starting & Power Loss
Replies and Fixes
Avatar
whittingehame
Legend
21,029 points

Nov 9, 2009 (11 years ago)
Very common fault , see here http://www.rac.co.uk/forum/showthread.php?t=1012

This problem is archived

If you're having a similar problem please click below to re-post this problem, you can then customise it to suit your situation.

What to do next?

Fix the problem yourself...

If you need parts to do the job head over to Euro Car Parts to find the parts you need.

  • Free UK Delivery
  • 365 Day Returns
  • Free Click and Collect
or Find a Local Mechanic

Use our AutoInsider Find A Specialist search, find garages and mobile mechanics near you.

Simply enter your postcode, select the required specialist areas and view your results.

Helpful & Related Pages on AutoInsider
Generated by AutoInsider AIBot
AutoInsider AI Robot picture
Having a problem with your Ford Fiesta?

Tell us about your Fiesta problem

On Social Media