Intermittent power loss
2006 Ford Fiesta 1.4 zetec climate

Avatar
dawsy29
Driver
2 points

Problem added: Aug 29, 2009 (11 years ago)
uneven idle on startup...nearly cuts out.
sometimes misfires and engine system failure light comes on, power is lost above 2000revs.once engine switched off and restarted fault clears.is ok for a few weeks.
diagnostic check done and error code states throttle problem,spent 200 quid on new throttle pedal but still the same. dont want to spend more money unless problem is identified.
been told throttle comes in about 4 parts,one of which i have replaced already.

Car details
Car: Ford Fiesta
Variant: 1.4 zetec climate
Model Year: 2006
Category: Running Rough, Starting & Power Loss
Replies and Fixes
Avatar
autoinsider
Top Fixer
939 points

Sep 1, 2009 (11 years ago)
Have you had a look at this similar problem: intermittent chugging

This message was auto-generated based on a user suggestion.

This problem is archived

If you're having a similar problem please click below to re-post this problem, you can then customise it to suit your situation.


Options for fixing the problem

Fix the problem yourself

If you need parts to do the job head over to Euro Car Parts to find the parts you need.

  • Free UK Delivery
  • 365 Day Returns
  • Free Click and Collect
Find a Local Mechanic

Use our AutoInsider Find A Specialist search, find garages and mobile mechanics near you.

Simply enter your postcode, select the required specialist areas and view your results.


Having a problem with your Ford Fiesta?

Tell us about your Fiesta problem